Today i migrated some of my kvm machine images from one physical machine to another, both machine has Ubuntu 18.04. But while starting virtual machine, i faced one issues that quit new for me.
But while doing bit investigation i found some of features was enabled that disabled on this new machine.

below are details for same

ssirohi@srv2:~$ virsh start centos6_1
error: Failed to start domain centos6_1
error: operation failed: guest CPU doesn't match specification: missing features: hle,rtm

earlier i thought it could be because it need root user to run these virtual machines, but that not the case. So i tried to run it through this way as well.

sudo virsh start centos6_1
[sudo] password for ssirohi:
error: Failed to start domain centos6_1
error: operation failed: guest CPU doesn't match specification: missing features: hle,rtm

As said while investigation I found one features that need to disable on this new machine, for same i need to edit xml file for kVM virtual machine through below command.

virsh edit centos6_1

Though above it will open one xml file that has all settings of this machine which is make it easy to edit machine settings before we start it.
So for my case (Above error comes while running Virtual machines) has some cpu check features.
This could be different for different setup, so might in your case you need to change it bit.

I added two more feature policy here like below

 
  <cpu mode='custom' match='exact' check='full'>  
  <model fallback='forbid'>Broadwell</model>    
  <feature policy='require' name='vme'/>        
  <feature policy='require' name='f16c'/>       
  <feature policy='require' name='rdrand'/>     
  <feature policy='require' name='hypervisor'/> 
  <feature policy='require' name='arat'/>       
  <feature policy='require' name='xsaveopt'/>   
  <feature policy='require' name='abm'/>        
  <feature policy='disable' name='rtm'/>        
  <feature policy='disable' name='hle'/>        
</cpu>                                          

Last two line added in above code

<feature policy='disable' name='rtm'/>
<feature policy='disable' name='hle'/>

After adding I tried to start same Virtual machine and this i was able to start it as it should be.